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Add, Delete and Sort Pages 

When you create a publication with InDesign, you can choose to specify the 
desired number of pages in the New Publication dialogue box. You can change 
your mind at any time, however, and add, delete and even sort pages on the fly 
in a number of ways. The easiest and most common way of managing your 
pages is through the Pages panel. The Pages panel allows you to add, delete, 
sort, duplicate and number your pages as well as create, modify and apply 
Master Pages throughout your publication (See Figure 1). 
 

 
 

Figure 1 ï The Pages Panel 

 

Sorting Pages 

 
To reposition or renumber pages within your publication, simply drag the page 
icon in the Pages panel to the position you want to move it to. Look for the 
vertical bar as you are dragging within the Pages panel to indicate where the 
page will be placed. 
 
To view a particular page of your publication in the Design window, double-click 
on the page (or page number) in the Pages panel. To select a page, click once 
on it (or its page number) in the Pages panel. To select a 2-page spread, click on 
the page numbers below the page spread icon. 
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Add Pages at the End of a Document 

 

 Choose File > Document set up and type in the total number of pages you 
want. The new pages will be added to the end of the publication. 

 Click on the New Pages button at the bottom of the Pages panel. One new 
page will be added at the end of the publication. 

 
 

Insert Pages in the Middle of a Document 

 

 Open the Pages panel, click on the Options menu and choose Insert Pages. 
Type in the number of pages you would like to add and select where in the 
document you want them to be inserted (See Figure 2). 

 

 
 

Figure 2 ï The Insert Pages Dialog Box 

 

Delete Pages 

 

 In the Pages panel, click on the page you want to delete and click on the 
Trash Can or go to the Options menu and choose Delete Page. 

 

See thumbnails of your pages in the Pages panel for easy navigation and page 
arrangement. View icons in the Pages panel to indicate youôve used 
Transparency or Rotate View on a particular page. 

 
Figure 3 ï Pages Panel Icons indicate Transparency or Rotate View 
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If transparency, page transitions, or spread rotation have been applied to pages, 
you can turn off their associated icons for a cleaner Pages panel. 

 

Pages Panel menu > Panel Options to change how you are viewing the pages 
panel. 

 

 
 
Figure 4 ï Panel Options control whether icons are visible or not in the Pages Panel to 

indicate Rotate View or Transparency used on the page. 

 

 

Master Pages 

A Master Page is like a background that you can quickly apply to many pages. 
InDesign allows you to create several master page layouts, allowing you to 
switch between recurring page layouts within a single publication. A prefix letter 
is assigned to each master page layout, and page icons in the Pages panel will 
show the prefix of which master, if any, they are based on (See Figure 5). 
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Figure 5 ï Master Labels 
 

About Master Pages 

 

 A master can be one page or a multiple-page spread. 

 Use masters for objects or guides that appear in the same position on many 
pages, such as margins, columns, page numbers, headers, footers, or 
repeating logos or artwork. 

 
Using masters can minimize the time you spend keeping your design consistent 
over many pages. 
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Adding Recurring Elements to a Master Page 

 

 Double-click the A-Master page icon in the top of the Pages panel to view 
and edit the master page spread. 

 There are two pages in the spread. Any changes made in the left-hand page 
will apply to all left-side pages in the publication. Any changes made in the 
right-hand page will apply to all right-side pages in the publication. 

 Add elements to the master pages that you would like to recur throughout the 
publication, such as a background, company logo, section heading, footer, 
etc. 

 Double-click back on one of the page icons with an óAô displayed to see the 
global changes applied. 

 
Any recurring elements applied to a page from a master will be treated like 
wallpaper on the individual pages within the publication. Any new content added 
to individual pages will appear on top of the master frame elements. 
 
 

Add Automatic Page Numbers to Each Page 

 

 Double-click the A-Master icon to open the master page. 

 Insert a text frame at the bottom of the left-hand page and choose  
Type > Insert Special Character > Markers > Current Page Number. 

 Format the text in the frame. 

 Repeat for the right-hand page. 
 
 

Creating a New Master 

 

 In the Pages panel Options menu, choose New Master. 

 Indicate a Prefix letter (or keep default) and give it a name. 

 Indicate the number of pages you want the master to have and click OK. 

 Double-click the new master in the top of the Pages panel to open it for 
editing. 

 
The default prefix letter for this master will be óBô. You can choose a different 
prefix if you like or keep the default. The next master you create will default to a 
prefix of óCô. 
 
You can give each master a name to describe its purpose in the publication. For 
example, say you are creating a company brochure with four different sections 
(Company Profile, Products, Services, & Management). Each section may have 
several pages with recurring elements within that section, and possibly some 
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recurring elements for the whole brochure. You could create a master page for 
each section with prefix/names. 
 

 
 

Figure 6 ï Naming Master Pages 

 

Applying Masters to Pages 

 
Once a master page has been created it can be applied to any page in the 
publication. 
 

 In the Pages panel, drag the master page icon over the page(s) you want to 
apply it to. 

 Or select the page(s) in the Pages panel and from the Options menu choose 
Apply Master to Pages. In the dialog box, choose the master you want to 
apply. 

 Notice the prefix of those pages now indicates the new master page. 
 
Any subsequent changes to a master will automatically be updated in all pages 
with that master applied to them. 
 
 

Override Master Objects 

 
All master page objects are by default locked in all of the document pages. They 
cannot be selected, edited, moved or deleted. The purpose of this is to help 
avoid making accidental changes and to ensure consistency. From time to time, 
however, you may want to unlock a master object on a given page and edit it 
individually. Here is how to do it: 
 

 On a document page (not a master), Ctrl+Shift+click on a master object to 
unlock and select it. 

 It is now unlocked from the master and you can make changes (overrides) as 
appropriate. These changes are called Local Overrides. 
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 To remove local overrides from an object, select it and from the Pages panel 
Options menu choose Remove Selected Local Overrides. 

 To remove all overrides from a spread: 
o Target the spread you want in the Pages panel. 
o Make sure nothing is selected (Ctrl+Shift+A). 
o From the Pages panel Options menu choose Remove All Local 

Overrides. 
 

Loading Master Pages 

Itôs easy to reuse Master Pages in more than one document by Loading Masters 
in the Pages panel. 

 

To copy a Master Page into another document: 

 Open the Pages panel from the Window menu. 

 Pages panel menu > Load Masters. 

 Browse to the document you wish to copy a master page from. 

 
 

Figure 7 ï Loading Masters 
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Ruler Guides 

In addition to margin and column guides that define each page, you can build 
ruler guides to help position and align objects. Ruler guides can be visible or 
hidden on-screen, but are never visible when printed. 
 
You can create two kinds of ruler guides: 

 Page Guides which apply only on the page on which you create them 

 Spread Guides which span all pages and the pasteboard of a multiple-page 
spread 

 
Choose View > Grids & Guides > Snap to Guides in order to easily align 
objects to the guides. 
Objects will snap to the guides regardless of whether they are visible or not. 
 

Creating Ruler Guides 

 

 Drag from one of the rulers and place the guide where desired. You can 
create as many horizontal and vertical guides as you wish. 

 To position a guide exactly, use the Transform panel and type in the exact 
position for the guide. 

 To lock guides choose View > Grids & Guides > Lock Guides. This will 
prevent you from accidentally repositioning the guides when attempting to 
move other objects. 

 To determine Page Guides or Spread Guides, select the appropriate content 
in Pages panel before creating your guides. 

 To remove a guide, simply drag it back to the ruler from where you created it. 
 
 

Controlling Text Flow 

The text in a frame can be independent of other frames or it can flow between 
connected frames. Text that flows through one or more frames is called a story 
and the process of connecting text among frames is called threading text. 
Threaded frames can be on the same page or spread or on another page in the 
publication. 
 
Each text frame contains an In Port and an Out Port control for connecting to 
other text frames. 

 An empty In Port or Out Port indicates the beginning or end of a story. 

 An arrow in a port indicates that the frame is linked to another frame. 
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 A red plus sign (+) in an out port indicates that there is more text in the story 
than can be displayed in the frame. The remaining unseen text is called 
overset text. 

 

 
 

Figure 8 ï Text Flow Indicators 
 

Threading a Story 

 
Typically long passages of text (stories) are created in a word processing 
application and later pasted or Placed into InDesign. A story can be distributed to 
text frames in three ways: 
 

 Manual flow adds text one frame at a time, returning the cursor to a pointer 
after placing each frame. 

 Autoflow adds pages and text frames until the entire story is placed into the 
document. 

 Semi-Autoflow adds text one frame at a time. After placing a text frame, the 
cursor remains loaded, allowing you to continue to place text. 

 
 

Manual Text Flow 

 

 Choose File > Place and select the file you want to place. 

 Place the loaded cursor in the column you want text to appear and click or 
click & drag. The text frame appears with a red plus in the lower right hand 
corner to indicate overset text. 

 To continue to place text, click on the text frameôs out port indicating overset 
text (box with the red plus in the lower right hand corner of the text frame) to 
load the cursor and click or click & drag to create the next text frame. 

 Repeat until the entire story is placed in frames. 
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Automatic Text Flow (Shift) 
 

 Make sure nothing is selected. 

 Choose File > Place and select the file you want to place. 

 Place the loaded cursor in the column you want text to start, hold the Shift 
key and click. The entire article will be placed in the publication. It will add 
new pages to the document if needed to accommodate the entire story. 

 
 

Semi-Automatic Text Flow (Alt / Option) 
 

 Make sure nothing is selected. 

 Choose File > Place and select the file you want to place. 

 Place the loaded cursor in the column where you want text to start, hold the 
Alt key and click. The article will flow into the column and the mouse will 
remain loaded. 

 Continue to point and click in the columns where you would like text to flow. 
 
 

Managing Text Frames 

 
You can move/resize/reshape text frames and text will be pushed/pulled 
dynamically from one frame to another. 
 
To see lines connecting frames which represent the actual flow of the story, 
select a frame and choose View > Show Text Threads. 
 
 

Insert a Text Frame 

 
Click on the Out Port or In Port of an existing text frame and, with your cursor 
loaded, click or click and drag to create a new frame. 
 
 

Eliminate a Text Frame 

 
Select the frame and hit Delete. The text will not be deleted but absorbed by the 
downstream frames. 
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Working with Shapes 

InDesign allows you to create simple shapes, also known as Paths ï such as 
lines, rectangles and ovals as well as complex polygons and stars. You can 
format your shapes by filling them with solid colors, gradients, patterns, text, or 
images and stroking them with a variety of line styles. Shapes are created in 
InDesign using Vector Paths, so familiarity with other vector programs (such as 
Adobe Illustrator or Macromedia Fireworks) and vector tools (such as the Pen 
tool) is helpful as the vector tools in InDesign work similarly to those in other 
graphics applications. 
 

Creating Lines and Shapes 

 

Lines 

 
The two tools used to easily create lines are the Line tool and the Pencil tool. 
The Line tool is used to create straight line segments and the Pencil tool is used 
to draw free-form lines. 
 

To create a straight line using the Line tool : 

 Select the Line tool from the Toolbox. 

 Click and drag on your document where you want the line to go. 

 Format the line using the Stroke panel. 
 

To create a free-form line using the Pencil tool : 

 Select the Pencil tool from the Toolbox. 

 Click and draw a free-form line on your document. 

 Format the line using the Stroke panel. 
 
 

Shapes  

 
As mentioned above, InDesign allows you to create a wide range of simple and 
complex shapes. The Shape tool is used to create shapes in InDesign. 
 

Create a Rectangle or Ellipse using the Shape tool: 

 Choose the appropriate shape from the Shape tool in the Toolbox (See 
Figure 6). 

 Click and drag on the document to create a shape of the dimensions you 
desire. 

Tip: Hold the 
Shift key on your 
keyboard when 
dragging out a 
line to constrain 
the direction of 
the line to 45° 
increments. 
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 To make your rectangle a square or your ellipse a circle, hold the Shift key on 
your keyboard while dragging out the shape. 

 Format the shape using the Color, Stroke, and Gradient Panels. 
 

 
 

Figure 9: Polygons and Stars created with the Polygon Tool 

 
Create a Polygon or Star using the Polygon Shape tool: 

 Choose the Polygon Tool from the Shape tool options in the Toolbox. 

 Click and drag on the document to create a shape of the dimensions you 
desire. 

 While dragging out the shape, press the up arrow key on you keyboard to 
increase the number of sides in the shape or press the down arrow key to 
decrease the number of sides. 

 To make the shape a Star, use the right/left arrow keys to increase/decrease 
the inset depth for the starôs points while you are dragging out the shape. 

 To predefine the number of sides and amount of inset for a star, double-click 
on the Polygon tool to open the Polygon Settings dialog box (See Figure 7). 

 Enter the number of sides and inset size and click OK. 
o Set the Star Indent to 0% to create a simple polygon with the given 

number of sides. 

 Drag out the shape in the design window. 
o You can still adjust the sides and indent using the arrow keys as 

you drag out the shape. 
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Figure 10 ï Polygon Settings 

 

Shape Frames 

 
Frames are identical to shapes (paths), with only one differenceðthey can be 
containers for text or other objects. A frame can also exist as a placeholderða 
container without contents. As containers and placeholders, frames are the basic 
building blocks for a documentôs layout. 
 
You can draw both paths and frames using tools in the Toolbox. You can also 
create frames by simply placing (importing) or pasting contents into a path. 
 
Because a frame is just a container version of a path, you can do anything to a 
frame that you can do to a path, such as add a color or a gradient to its fill or 
stroke, or edit the shape of the frame itself with the Pen tool. You can even use a 
frame as a path, or vice versa, at any time. This flexibility makes it easy to 
change your design, and provides a wide range of design choices. 
 
Frames can contain text or graphics. A text frame determines the area to be 
occupied by text, and how text will flow through the layout. You can recognize 
text frames by the text ports in their respective upper left and lower right corners. 
 
A graphics frame can function as a border and background, and can crop or 
mask a graphic. When acting as an empty placeholder, a graphics frame displays 
a crossbar (See Figure 11). 
 

 
 A B C 

 
Figure 11 ï A. Shape   B. Frame as a Graphics Container    

C. Frame with Placed Graphic 
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Create a Shape Frame using the Frame tool : 

 Choose the appropriate shape frame from the Frame tool in the Toolbox. 

 Click and drag on the document to create a shape of the dimensions you 
desire. 

o Just as when using the shape tools you can constrain the 
proportions by holding the shift key and you can modify a polygon 
or star using the arrow keys. 

 
 

Importing Graphics into Frames 

 
All graphics, whether they are imported through the Place command or copied 
and pasted into the publication, exist inside of frames. If you import a graphic 
without first drawing or selecting a frame, InDesign will automatically generate a 
new frame for you. You can also place a graphic into an already existing 
placeholder frame. 
 
Place a Graphic in a Selected Frame 

 Select a frame in the design window and choose File > Place. 

 Browse to the image you wish to use and click Open. 

 The image will appear inside and be cropped by the shape. 

 To reposition the image in the frame, select the frame and click on the Select 

Content button  in the Control panel. Use your Select tool or arrow keys to 
reposition the image in the frame. 

 
Import a Graphic into an Unselected Frame 

 Choose File > Place and browse to select the graphic you want to place in 
the publication. 

 Click the loaded graphics icon anywhere in the pre-drawn frame. 
 
Import a Graphic into a New Frame 

 Choose File > Place and browse to select the graphic you want to place in 
the publication. 

 Click the loaded graphics icon in the layout where you want the upper left 
hand corner of the graphic to appear. 

 
Creating a Graphics Placeholder Frame 

 Choose a Shape tool from the toolbox. 

 Click and drag a shape in the area you want to reserve for a graphic. 

 Make sure the shape is selected. 

 Choose Object > Content > Graphics. 
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Using the Align Panel 

Aligning and Centering Objects 

The Align panel can be used to align objects with each other, or align objects to 
the page or margins. 

 
Figure 12 ï Aligning Objects (Align to Selection) 

 

 
Figure 13 ï Centering Objects on the Page 

 



Adobe InDesign CS4 ï Module 2 19 Learn iT Computer Training School 

Smart Guides 

 

Smart Guides 

Align, space, rotate, and resize multiple objects easily. Align to the horizontal, 
vertical, or center of page edges. The guides, object dimensions, rotation, and 
X,Y coordinates appear dynamically so you can snap objects in relation to other 
objects in the layout. 

 
Figure 14 ï With Smart Guides turned on, it is easy to rotate an object to match the 

angle of a nearby object. Angle icons appear when the angle matches, and snaps the 
object to match the neighboring object. 

 

 

 
 

Figure 15 ï Toggle Smart Guides on or off in the View menu or use Ctrl U. 
 

Turn smart guides on or off 

 Choose View > Grids & Guides > Smart Guides. 
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Turn smart guide categories on or off 

1. Open the Guides & Pasteboard preferences. 

2. Indicate whether you want Align To Object Center, Align To Object Edge, 
Smart Dimensions, and Smart Spacing turned on or off, and click OK. 

 

Change the appearance of smart guides 

1. Open the Guides & Pasteboard section of the Preferences dialog box. 

2. Choose a different color from the Smart Guides menu, and click OK. 

 
 

Smart Dimensions 

When you create, resize, or rotate one object, Smart Dimensions shows the 
width, height, or rotation of your object, highlighting with arrows when the 
dimensions or rotation matches nearby objects. 

Smart dimension feedback appears when youôre resizing, creating, or rotating 
page items. For example, if you rotate one object on your page 24 degrees, a 
rotation icon appears as you rotate another object close to 24 degrees. This hint 
lets you snap the object to the same rotation angle of the adjacent object. 
Similarly, as you resize an object next to another object, a line segment with 
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arrows at each end lets you snap the object to the same width or height as 
the adjacent object. 

Smart Spacing 

Evenly space multiple items on your page by snapping objects into position 
without having to use the Align panel. Smart spacing lets you quickly arrange 
page items with the help of temporary guides that indicate when the spacing 
between objects is even. 

Smart Cursors 

When transforming objects, the cursor displays X and Y position, width and 
height, or rotation information. The Show Transformation Values option in 
Interface preferences lets you turn smart cursors on and off. 

 
Figure 16 ï Smart Cursors displays location and size information. 

 

 
 

Figure 17 ï Use Interface Preferences to change Cursor Options. 

 



Adobe InDesign CS4 ï Module 2 22 Learn iT Computer Training School 

Tips for using Smart Guides 

Smart Guides take effect only on page items and intersections that are in the 
current page view. If you have many objects on a page and are trying to align an 
object to another object or objects in particular, zoom in on that area specifically. 

 If you donôt want Smart Guides to snap to column guides, turn off Snap To 
Guides temporarily by choosing View > Grids & Guides > Snap To Guides. 

 The Smart Guides feature is accurate regardless of zoom percentage, so it 
isnôt necessary to zoom in to see if two objects are really aligned at their left 
edges, for example. 

 

Wrapping Text 

 
You can wrap text around any object; including text frames, imported graphics, 
and objects you draw in InDesign. When you apply a text wrap to an object, 
InDesign automatically creates a boundary around the object that repels text. 
The object that text wraps around is called the wrap object. 
 

 
 

Figure 18 ï Text Wrapping Around Images 
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Wrap Text Around Shapes and Imported Graphics 

 

 Place the shape or graphic frame over the text you want to wrap. 

 Open the Text Wrap panel. 

 Choose the various wrapping buttons at the top of the panel. 
 

 
 

Figure 19 ï Text Wrap Panel 

 
 

 Establish wrap offset values if desired. This allows you to adjust how much 
space is created between the object and the text. 

 To modify the text wrap boundary based on the image composition, choose 
Detect Edges in the Text Wrap panel. 

 To manually adjust edge detection use the Pen tool and Direct Selection 
tool to modify the path from the frame. 

 
Regardless of the type of object or the text wrap method you use, you can 
always manually adjust the resulting text wrap boundary. 
 


